summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072018-07-03 17:26:05 +0200
committersL1pKn072018-07-03 17:26:05 +0200
commit40d3d7717053018e3f3763f1f01151aed39f1e8c (patch)
treed468db28bef45b7a0ec59c30e38da7c54867683a /PKGBUILD
downloadaur-40d3d7717053018e3f3763f1f01151aed39f1e8c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb099ca2f28a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Martins Mozeiko <martins.mozeiko@gmail.com>
+
+pkgname=pkg2zip-git
+pkgver=v1.8.1.gfccad26
+pkgrel=1
+arch=('x86_64')
+pkgdesc='Decrypts PlayStation Vita pkg file and packages to zip archive. (GIT version)'
+url='https://github.com/mmozeiko/pkg2zip'
+license=('custom:unlicense')
+depends=('glibc')
+source=('git+https://github.com/mmozeiko/pkg2zip.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pkg2zip
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd pkg2zip
+ make CFLAGS="${CFLAGS} -Wno-format-truncation"
+}
+
+package() {
+ cd pkg2zip
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 pkg2zip "${pkgdir}"/usr/bin/pkg2zip
+}