summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjurajmatus2023-01-10 07:10:28 +0100
committerjurajmatus2023-01-10 07:12:57 +0100
commit258ad0998922bc153dcf707140fe205d95ea86a6 (patch)
tree9fd0212863114fe350bb9b06a52c7c01cbce0b8e /PKGBUILD
parent20c84a9995d28039def5d76e978148ebe3be4586 (diff)
downloadaur-258ad0998922bc153dcf707140fe205d95ea86a6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 30 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bd7cb080097..6e0542360a34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer : Juraj Matuš <matus.juraj at yandex dot com>
-# Maintainer: Your Name <youremail@domain.com>
-pkgname="YoLang"
-pkgver="1.2.15"
+_lang=slk-eng
+pkgname=dict-freedict-${_lang}
+pkgver=0.2
pkgrel=1
-pkgdesc="Lightweight, simple interpretive programming language"
-arch=("any")
-url="https://github.com/PowerAngelXD/YoLang"
-license=("MIT")
-makedepends=("cmake"
- "make")
-provides=("yolang")
-source=("$pkgname-$pkgver.zip::https://github.com/PowerAngelXD/YoLang/archive/refs/heads/master.zip")
-md5sums=("764407b9d4a7267dc857555a6a2fdaef")
+pkgdesc="Slovak -> English dictionary for dictd et al. from Freedict.org"
+arch=('any')
+url="https://freedict.org/"
+license=('GPL')
+optdepends=('dictd: dict client and server')
+makedepends=('dictd' 'freedict-tools')
+install=install.sh
+source=("https://download.freedict.org/dictionaries/${_lang}/${pkgver}.${pkgrel}/freedict-${_lang}-${pkgver}.${pkgrel}.src.tar.xz")
+sha512sums=('ba7669020a12f64f7d2e2b6dfa90f1376df4a2fe764273bdb06f1e04998ee6dac9584b47f20f8e14cbaae5bf7271dd221032bcc34bd1ff7c93a93cf9de4429ac')
-# prepare() {
-# cd "$pkgname-$pkgver"
-# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
-# }
-
-build() {
- cd "$pkgname-master"
- cmake -S .
- make
+build()
+{
+ cd $_lang
+ make FREEDICT_TOOLS=/usr/lib/freedict-tools build-dictd
}
-package() {
- cd "$pkgname-master"
- mkdir "$pkgdir/usr"
- mkdir "$pkgdir/usr/bin"
- install -m=777 "yolang" "${pkgdir}/usr/bin"
+package()
+{
+ install -m 755 -d "${pkgdir}/usr/share/dictd"
+ install -m 644 -t "${pkgdir}/usr/share/dictd/" \
+ ${_lang}/build/dictd/${_lang}.{dict.dz,index}
+
+ for file in ${_lang}/{AUTHORS,README,NEWS,ChangeLog}
+ do
+ if test -f ${file}
+ then
+ install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" ${file}
+ fi
+ done
}