summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRvn0xsy2022-09-02 00:59:15 +0800
committerRvn0xsy2022-09-02 00:59:15 +0800
commit2e3a7c3e882451ee688c33f99c7dd0e69fb79222 (patch)
treefcfabea7362da3f88a4a4240be164f162db48369 /PKGBUILD
parent27c71e596959b5c0e7f8b8f5174f0a49073a53a1 (diff)
downloadaur-2e3a7c3e882451ee688c33f99c7dd0e69fb79222.tar.gz
red-tldr v0.4.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 13 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8215ea33145d..9cb911e1f271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,16 @@
-# Maintainer: Ayush Jha <ayushjha@pm.me>
-pkgname=nekuvi
-pkgver=0.2
-pkgrel=1
-epoch=
-pkgdesc="नेपाली कुन्जीपेटि विन्यास A better layout for Nepali Keyboards based for xkb system"
-arch=("any")
-url="https://gitlab.com/ayys/nekuvi"
-license=('GPL')
-groups=()
-depends=("xkeyboard-config")
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("install.sh" "uninstall.sh" "level3_np" "np" "layout-evdev-install.hook" "layout-evdev-remove.hook")
-sha256sums=('27bd5a76ef85a97a95248a5530446c3362064aab2146f8d7ceefdf8969a7a7c7'
- '0614ff1b4abd4fe0fb07cf95ebb60dee90180dadf19232b8e5fc94d75d67e555'
- 'd5965a2ad14b8d9f6bed0bfdd37282dc1a67938577fa7fbe53d56be305583688'
- '819c86fecd6ec4a9ec57308fb00b13ffb040b238b29cf9564934d23692d4a917'
- '978abf768110916b04c10c3fd7690370b3e55d98090a5a411faf586ca8e48756'
- '3ec3ebb0324103f747b0e1ef7828664596b5db87ab82202a8213ed743025115b')
+# Maintainer: Rvn0xsy <rvn0xsy@gmail.com>
+# Contributor: Rvn0xsy <rvn0xsy@gmail.com>
+pkgname="red-tldr"
+pkgver="0.4.3"
+pkgrel="1"
+pkgdesc="red-tldr is a lightweight text search tool, which is used to help red team staff quickly find the commands and key points they want to execute, so it is more suitable for use by red team personnel with certain experience."
+arch=("x86_64")
+license=("custom")
+url='https://github.com/Rvn0xsy/red-tldr'
-
-noextract=()
-validpgpkeys=()
+source=("https://github.com/Rvn0xsy/red-tldr/releases/download/v${pkgver}/red-tldr_${pkgver}_linux_amd64.tar.gz")
+sha512sums=("aa4ce44d2e8a84d1e0bf390cb5ed28e40458645313a5a48ec24d07ecf494928694eb60452c91b03df33f6abe6e604d1be37b8b42069ebb2703e0dedd63845c32")
package() {
- set -euxo pipefail
- echo $pkgdir
-
- mkdir -p "$pkgdir"/usr/share/X11/xkb/symbols/
- mkdir -p "$pkgdir"/usr/share/X11/xkb/rules/
- cp level3_np "$pkgdir"/usr/share/X11/xkb/symbols/
- cp np "$pkgdir"/usr/share/X11/xkb/symbols/np_prog
-
- install -Dm 755 "${srcdir}"/install.sh "${pkgdir}/usr/share/libalpm/scripts/install-nekuvi-layout"
- install -Dm 755 "${srcdir}"/uninstall.sh "${pkgdir}/usr/share/libalpm/scripts/uninstall-nekuvi-layout"
- install -Dm 644 "${srcdir}"/layout-evdev-install.hook "${pkgdir}"/usr/share/libalpm/hooks/nekuvi-layout-evdev-install.hook
- install -Dm 644 "${srcdir}"/layout-evdev-remove.hook "${pkgdir}"/usr/share/libalpm/hooks/nekuvi-layout-evdev-remove.hook
-}
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file