summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormonkey ball2022-02-15 00:10:42 +0000
committermonkey ball2022-02-15 00:13:20 +0000
commitcb4a1c097a69fd8da8055e0458d245f5ffe437b4 (patch)
treeaed90b5c5d46eb90919e5a14a3c9f30d48a24812 /PKGBUILD
parent2e569be927268f5ee4cac24c8c3e0429dcd16e6f (diff)
downloadaur-cb4a1c097a69fd8da8055e0458d245f5ffe437b4.tar.gz
deez nuts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 28 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 131a3f60f0a2..cd37207b1af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
-# Maintainer: Rayr https://rayr.ml/LinkInBio/
-pkgname=discord-rpc-cli-git
-pkgver=1.1.0
+# Maintainer: monkeyballs <mydick@cunny.com>
+
+pkgname="satania-buddy-git"
+_pkgname="sataniabuddy"
+pkgver=r68.ade3a6f
pkgrel=1
-pkgdesc="A Discord RPC cli client written purely in Rust"
-arch=(any)
-url="https://github.com/Rayrsn/Discord-RPC-cli"
-license=('GPL')
-makedepends=('rust')
-source=("https://github.com/Rayrsn/Discord-RPC-cli/archive/refs/tags/$pkgver.zip")
-md5sums=(SKIP)
+pkgdesc="Virtual Satania Desktop Assistant"
+arch=("x86_64" "i686")
+url="https://git.cianig.ga/monkeyballs/sataniabuddy"
+license=('AGPL')
+depends=("openmotif" "cairo" "xorg-server")
+makedepends=("git" "make" "gcc")
+provides=("satania-buddy")
+conflicts=("satania-buddy")
+options=()
+source=(git+https://git.cianig.ga/monkeyballs/sataniabuddy)
+md5sums=('SKIP')
+prepare() {
+ cd "$srcdir"/"$_pkgname"
+ sed -i "s/AssetDirectory = \"\/usr\/local\/share\/satania\/assets\"/AssetDirectory = \"\/usr\/share\/satania\/assets\"/" main.c
+}
build() {
- cd "Discord-RPC-cli-$pkgver"
- cargo build --release
+ cd "$srcdir"/"$_pkgname"
+ make
+}
+pkgver() {
+ cd "$srcdir"/"$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
package() {
- cd "Discord-RPC-cli-$pkgver"
- install -Dm755 "target/release/Discord-RPC-cli" "$pkgdir/usr/bin/discord_rpc_cli"
-
+ cd "$srcdir"/"$_pkgname"
+ make PREFIX="$pkgdir/usr" install
}