summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDave Reisner2019-04-27 07:00:36 -0400
committerDave Reisner2019-04-27 07:00:36 -0400
commit19e65235df0d447da25140bcb041407b48694893 (patch)
tree66b207112858ca366fc608152757845c77af4b2c /PKGBUILD
parente6051f73eb84aab7045d269d4b96ef784ace14e1 (diff)
downloadaur-pkgbuild-introspection-git.tar.gz
Bump version, add check function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb736c2d6a03..de97c383d893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pkgbuild-introspection-git
_pkgname=pkgbuild-introspection
-pkgver=6.4.ga135f86
+pkgver=9
pkgrel=1
pkgdesc='Tools for generating .SRCINFO files and PKGBUILD data extraction (mkaurball)'
url="https://github.com/falconindy/$_pkgname"
@@ -10,6 +10,7 @@ license=('MIT')
arch=('any')
depends=('bash' 'pacman')
makedepends=('git')
+checkdepends=('python-srcinfo')
provides=('pkgbuild-introspection')
conflicts=('pkgbuild-reflection-git' 'pkgbuild-introspection')
source=("git://github.com/falconindy/$_pkgname.git")
@@ -27,6 +28,12 @@ build() {
make
}
+check() {
+ cd "$_pkgname"
+
+ make check
+}
+
package() {
cd "$_pkgname"