summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas18182020-11-18 15:14:42 +0100
committerLukas18182020-11-18 15:14:42 +0100
commitf90c5d5857e521c77dd68ee6e02356aa68edc695 (patch)
tree498e339591717ba1014137c927093faee8aef499 /PKGBUILD
downloadaur-f90c5d5857e521c77dd68ee6e02356aa68edc695.tar.gz
init repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0142baf8d0f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=pkgbuild-version-updater
+pkgver=0.1.0
+_pkgtag=$pkgver
+pkgrel=1
+pkgdesc="This script allows you to automatic update a large nummner of PKGBUILD files and push them to the aur, if only the pkgver and the checksum has been changed. As example this is very useful for gog games with many DLCs."
+arch=('x86_64')
+url="https://gitlab.com/Lukas1818/pkgbuild-version-updater"
+license=('LGPL3')
+depends=('git' 'coreutils' 'pacman' 'bash')
+source=("https://gitlab.com/Lukas1818/pkgbuild-version-updater/-/archive/$_pkgtag/pkgbuild-version-updater-$_pkgtag.tar.gz")
+sha512sums=('58a4c2d1f673d85c8bd7f0872e381621779dc210c360ef9b37215c5c85f9d1376cf88af8f4bece113ac48fe0660ef520b9e3bc56e77e0074d90b7b2ac1b7f96a')
+
+
+package()
+{
+ install -Dm 755 "${srcdir}/pkgbuild-version-updater-$_pkgtag/pkgbuild-version-updater.sh" "${pkgdir}/usr/bin/pkgbuild-update"
+}