summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsirlucjan2015-06-08 18:44:33 +0200
committersirlucjan2015-06-08 18:44:33 +0200
commit4df8cb74f599273e12192fce8cfe84e583f58556 (patch)
tree641b777865a64efe9a77e20ced1d5746f5187091 /PKGBUILD
downloadaur-4df8cb74f599273e12192fce8cfe84e583f58556.tar.gz
Add 0.9.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbc027c1a698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com>
+# Contributor: Bartlomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=pkgconf-git
+pkgver=0.9.11.3.gfc18a9d
+pkgrel=2
+pkgdesc='pkg-config compatible utility which does not depend on glib'
+url='https://github.com/pkgconf/pkgconf'
+arch=('i686' 'x86_64')
+license=('ISC')
+makedepends=('popt' 'git')
+conflicts=('pkg-config' 'pkgconfig' 'pkgconf')
+provides=('pkg-config' 'pkgconfig' 'pkgconf')
+replaces=('pkg-config' 'pkgconfig' 'pkgconf')
+source=(git://github.com/pkgconf/pkgconf.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd pkgconf
+ git describe --tags | sed 's/^v//;s/-/./g;s/pkgconf.//'
+}
+
+build() {
+ cd pkgconf
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd pkgconf
+ make DESTDIR="$pkgdir" install
+ ln -s /usr/bin/pkgconf "$pkgdir"/usr/bin/pkg-config
+}