summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDennis Mellert2020-01-17 17:30:14 +0100
committerDennis Mellert2020-01-17 17:30:35 +0100
commit3a72046b2f4da0fa2d5c6931eda49f8d59b59af1 (patch)
tree66efacd71fc055fe8a025240524e10e21e4f44d4 /PKGBUILD
downloadaur-3a72046b2f4da0fa2d5c6931eda49f8d59b59af1.tar.gz
pkghist 0.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f18cef8ac2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: herzrasen <dennis@herzrasen.me>
+pkgname=pkghist-bin
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="Query your pacman logs. Precompiled binary."
+arch=('x86_64')
+url="https://github.com/herzrasen/pkghist"
+license=('MIT')
+depends=('git')
+
+provides=('pkghist')
+conflicts=('pkghist')
+
+source=("${pkgname/-bin/}-${pkgver}.tar.gz::https://github.com/herzrasen/${pkgname/-bin/}/releases/download/v${pkgver}/${pkgname/-bin/}.tar.gz")
+sha1sums=('80c890b66e844fbc44e412966580dc8994a06d38')
+
+package() {
+ _pkg="${pkgname/-bin/}"
+ install -Dm755 ${_pkg} "${pkgdir}/usr/bin/${_pkg}"
+ install -Dm644 completions/_${_pkg} "${pkgdir}/usr/share/zsh/site-functions/_${_pkg}"
+ install -Dm644 completions/${_pkg}.bash "${pkgdir}/usr/share/bash-completion/completions/${_pkg}"
+ install -Dm644 completions/${_pkg}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkg}.fish"
+}
+