summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2021-01-28 16:45:11 +1000
committerMark Blakeney2021-01-28 16:45:11 +1000
commit208ec3ed2d7f94d4a9fb8ff8b10647c5c99a4796 (patch)
tree7b3a6cd4f30cf999879c5805a3964c10e058369f /PKGBUILD
parent12c573bc315aa0544b47891d4f09f6ab2bad35c9 (diff)
downloadaur-208ec3ed2d7f94d4a9fb8ff8b10647c5c99a4796.tar.gz
Update to 1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 24 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a774038b851f..1bb8e7a21c0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,38 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=pkglog
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="Reports log of package updates"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
depends=("python>=3.7")
-makedepends=("python-setuptools")
+makedepends=("python-pip" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('cf733bcb69343b9c1f9f52d770c86c751e6a0aad')
+sha1sums=('e4d4d0ce488d83fa5055839b4b13dff7d19ed853')
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --disable-pip-version-check \
+ --no-python-version-warning \
+ --no-warn-script-location \
+ --no-cache-dir \
+ --no-compile \
+ --progress-bar=off \
+ .
+
+ local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
+ local _pkgname="${pkgname//-/_}"
+ cd "$pkgdir/$pdir"
+ rm -f $_pkgname-*.dist-info/direct_url.json
+ sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
+ python -O -m compileall -q .
}
# vim:set ts=2 sw=2 et: