summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2022-10-10 09:50:24 +1000
committerMark Blakeney2022-10-10 09:50:24 +1000
commitd9b4251e9e834fad7f5ed716e5401e69e2524cf7 (patch)
treef148ecd0fdf4e24dcd651b0416c35fbc781775f3 /PKGBUILD
parentc3e4f8acb66873a4ede72bef9180058c21b5d310 (diff)
downloadaur-d9b4251e9e834fad7f5ed716e5401e69e2524cf7.tar.gz
Simplify PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 9 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 801e511bb9dd..3bde2ef84ab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,21 @@ pkgver=1.8
pkgrel=1
pkgdesc="Reports log of package updates"
url="https://github.com/bulletmark/$pkgname"
-license=("GPL3")
-arch=("any")
+license=(GPL3)
+arch=(any)
depends=("python>=3.7" "python-rich")
-makedepends=("python-pip" "python-wheel")
+makedepends=(python-setuptools python-build python-installer python-wheel)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha1sums=('a2ed25fc4d0024b3e4482e11e19c0dcabe24f6db')
-package() {
+build() {
cd "$srcdir/$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
- PIP_CONFIG_FILE=/dev/null pip install \
- --root="$pkgdir" \
- --isolated \
- --ignore-installed \
- --no-deps \
- --disable-pip-version-check \
- --no-python-version-warning \
- --no-warn-script-location \
- --no-cache-dir \
- --no-compile \
- --progress-bar=off \
- --root-user-action=ignore \
- .
-
- local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
- local _pkgname="${pkgname//-/_}"
- cd "$pkgdir/$pdir"
- rm -f $_pkgname-*.dist-info/direct_url.json
- sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
- python -O -m compileall -q .
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: