summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiachen Yang2015-08-10 19:10:12 +0900
committerJiachen Yang2015-08-10 19:10:12 +0900
commit700e1bffd16b935a5db7c1ae973817f1bbb81d39 (patch)
tree0a19482d1129990b6ef8fa730cae176c4906de89 /PKGBUILD
downloadaur-700e1bffd16b935a5db7c1ae973817f1bbb81d39.tar.gz
takeover pkgtools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee1e334cfcf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: farseerfc <farseerfc@archlinuxcn.org>
+# Contributor: Nyarcel <nyarcel AT SPAMFREE gmail DOT com>
+# Contributor: Lara Maia <lara@craft.net.br>
+# Contributor: BlackICE <manfredi at gmail.com>
+# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
+
+pkgname=pkgtools
+pkgver=25
+pkgrel=5
+pkgdesc="A collection of scripts for Arch Linux packages"
+arch=('any')
+url="https://bbs.archlinux.org/viewtopic.php?pid=384196"
+license=('GPL')
+depends=('coreutils' # for comm in whoneeds
+ 'bash>=4'
+ 'pcre'
+ 'libarchive'
+ 'python')
+optdepends=('abs: Provides PKGBUILD prototypes for newpkg'
+ 'gem2arch: Create PKGBUILD from Ruby Gem Package'
+ 'pkgfile: Required to use pkgconflict'
+ 'namcap: Package analyzer')
+provides=('newpkg' 'pip2arch')
+backup=('etc/pkgtools/newpkg.conf'
+ 'etc/pkgtools/pkgfile.conf'
+ 'etc/pkgtools/spec2arch.conf')
+install=pkgtools.install
+source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/Daenyth/pkgtools/tarball/v$pkgver"
+ "https://raw.githubusercontent.com/bluepeppers/pip2arch/master/pip2arch.py" # submodule issue
+ 'whoneeds.bash')
+md5sums=('9e9d7aad5ba8ecee1b798c3ed4e0a0a7'
+ '9267993a72489019ec1536c887304374'
+ 'e0b7b1b320ead7a552be1b9eae29b494')
+
+prepare() {
+ cp -f pip2arch.py Daenyth-"$pkgname"-*/scripts/pip2arch/
+}
+
+package() {
+ cp whoneeds.bash "$srcdir"/Daenyth-"$pkgname"-*/scripts/
+
+ cd Daenyth-"$pkgname"-*
+
+ make DESTDIR="$pkgdir" install
+}