summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsian14682021-10-30 15:16:14 +0700
committersian14682021-10-30 15:16:14 +0700
commit25b5cb2a46e7101aedc917ef9e40ac2a320729fb (patch)
tree9e04a68c28e440127dbd74b2ea8b2ec9da0418c4 /PKGBUILD
parent7b9c03f48eb676bd0198ff7b8d28a5020b15c992 (diff)
downloadaur-25b5cb2a46e7101aedc917ef9e40ac2a320729fb.tar.gz
0.11.89.r6.g21d15e7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a6131196c8d..be301ab987ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Sian1468 <setthawut DOT a AT protonmail DOT com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
# Contributor: dcelasun <dcelasun@gmail.com>
pkgname=plank-git
-pkgver=0.11.89.r5.20c16a0
+pkgver=0.11.89.r6.g21d15e7
pkgrel=1
pkgdesc='Elegant, simple, clean dock'
arch=('x86_64')
@@ -19,24 +20,21 @@ sha256sums=('SKIP')
pkgver() {
cd plank
-
- echo "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
cd plank
-
./autogen.sh \
--prefix='/usr' \
--sysconfdir='/etc' \
--disable-apport
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd plank
-
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" -C plank install
}
# vim: ts=2 sw=2 et: