summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-01 23:36:50 +0000
committerJoão Figueiredo2021-02-01 23:36:50 +0000
commit1b0eb4361032ccfbe575273b7823ca186d9d6b36 (patch)
treeec12be78e53db4eb3b6e75d06c25c65f8d9c0fd0 /PKGBUILD
parent46fec87ea9c1ccccb0264822f8a7125f22cad805 (diff)
downloadaur-1b0eb4361032ccfbe575273b7823ca186d9d6b36.tar.gz
Merged with official ABS plasma-browser-integration PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 17 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 149782c40367..79425772ec56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,34 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+# Merged with official ABS plasma-browser-integration PKGBUILD by João, 2021/01/31 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
-_gitname=plasma-browser-integration
-pkgname=$_gitname-git
-pkgver=r1114.365e08e6
+pkgname=plasma-browser-integration-git
+pkgver=5.21.80_r1208.g3d1b0191
pkgrel=1
pkgdesc='Components necessary to integrate browsers into the Plasma Desktop'
-arch=(i686 x86_64)
+arch=($CARCH)
url='https://www.kde.org/plasma-desktop'
license=(GPL)
-depends=(krunner)
-makedepends=(extra-cmake-modules git python)
-conflicts=(plasma-browser-integration)
-provides=(plasma-browser-integration)
-source=('git+https://github.com/KDE/plasma-browser-integration.git')
+depends=(krunner-git purpose-git kfilemetadata-git)
+makedepends=(git extra-cmake-modules-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(plasma-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- mkdir -p build
-
- sed -e 's|${MOZILLA_PREFIX}|${CMAKE_INSTALL_PREFIX}|g' -i $_gitname/CMakeLists.txt
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../$_gitname \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
+ cmake -B build -S ${pkgname%-git} \
-DINSTALL_CHROME_MANIFEST=ON
- make
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}