summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-06-10 01:06:09 +0100
committerJoão Figueiredo2023-06-10 01:06:09 +0100
commitae6884d8b75c462b83d6363b73d5b0cb735d79a1 (patch)
tree88403ddca80e44a84578e3e9c4e5b320f7dcb3bd /PKGBUILD
parent4e10fb70fce93627a4de54771a43948522a00358 (diff)
downloadaur-ae6884d8b75c462b83d6363b73d5b0cb735d79a1.tar.gz
Migrate to Qt6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afab19a185c7..d3deeec8b527 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
pkgname=plasma-desktop-git
-pkgver=5.22.80_r8480.g7452d5c9b
+pkgver=5.27.80_r10537.g60ed932eb
pkgrel=1
pkgdesc='KDE Plasma Desktop'
arch=($CARCH)
@@ -20,7 +20,7 @@ optdepends=('plasma-nm-git: Network manager applet'
conflicts=(${pkgname%-git} user-manager knetattach user-manager-git knetattach-git)
provides=(${pkgname%-git} user-manager knetattach user-manager-git knetattach-git)
replaces=(user-manager-git knetattach-git)
-makedepends=(git extra-cmake-modules-git kdoctools-git xf86-input-evdev xf86-input-synaptics xf86-input-libinput xorg-server-devel scim kdesignerplugin-git kaccounts-integration-git intltool packagekit-qt5 kinit-git)
+makedepends=(git extra-cmake-modules-git kdoctools-git xf86-input-evdev xf86-input-synaptics xf86-input-libinput xorg-server-devel scim kdesignerplugin-git kaccounts-integration-git intltool packagekit-qt6 kinit-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
@@ -32,6 +32,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DCMAKE_INSTALL_LIBEXECDIR=lib \
-DBUILD_TESTING=OFF
cmake --build build