summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgustawho2021-06-10 12:04:32 -0600
committergustawho2021-06-10 12:04:32 -0600
commitbcaf231ad26cd63c6552e830dc75856eec7b6f81 (patch)
treef425e7f8ced7e17d004dd0cf0c9573cd8fbb8ebe /PKGBUILD
downloadaur-bcaf231ad26cd63c6552e830dc75856eec7b6f81.tar.gz
Plasma Mobile Gear 21.06
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ad534e8dbdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=plasma-dialer-git
+pkgver=21.06
+pkgrel=1
+arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+pkgdesc="Dialer for Plasma Mobile"
+url="https://invent.kde.org/plasma-mobile/plasma-dialer"
+license=('GPL2')
+depends=('kcontacts' 'kirigami2' 'ki18n' 'kconfig' 'kpeople' 'kcoreaddons' 'kdbusaddons'
+ 'knotifications' 'libqofono-git' 'telepathy-qt' 'libpulse' 'libphonenumber')
+makedepends=('extra-cmake-modules' 'qt5-svg' 'qt5-tools')
+source=("https://download.kde.org/stable/plasma-mobile/${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('SKIP')
+
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S "${pkgname}-${pkgver}"
+ cmake --build build --config Release
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build --config Release
+} \ No newline at end of file