summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeo P2020-01-14 15:14:36 -0500
committerLeo P2020-01-14 15:14:36 -0500
commit1df3d5a64b82fcfaa4eb7525dbbf2caca686bc21 (patch)
tree68f64c33aee0f12df9a0a429dabfd397411b674d /PKGBUILD
parent65d83ae9457933c37ee5ad4af5db7fba66e020f0 (diff)
downloadaur-1df3d5a64b82fcfaa4eb7525dbbf2caca686bc21.tar.gz
asciiquarium now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0b6c0f36b94..d77ae5f7912a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,6 @@
-# Maintainer: Jiri Tyr <jiri dot tyr at gmail dot com>
-
-pkgname='plasma-wallpaper-neon-particles-bzr'
-_pkgname="${pkgname%-bzr}"
-pkgver='0.1.7'
-pkgrel=2
+pkgname='plasma-wallpaper-asciiquarium-git'
+pkgver=r33.4d6e48a
+pkgrel=1
pkgdesc='Plasma Wallpaper Neon Particles from Ivan Safonov'
arch=('any')
url='https://code.launchpad.net/~ivan-safonov/+junk/plasma-wallpaper-neon-particles'
@@ -11,23 +8,21 @@ license=('GPL')
depends=('plasma-workspace')
makedepends=('cmake' 'extra-cmake-modules' 'bzr')
provides=("${pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::bzr+https://code.launchpad.net/~ivan-safonov/+junk/${_pkgname}")
+source=("git+https://anongit.kde.org/scratch/mpyne/plasma_wallpaper_asciiquarium.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${_pkgname}"
-
- printf "%s.%s" $(grep -P -o '(?<=set\(PROJECT_VERSION ")(.[^"]+)' CMakeLists.txt) $(bzr revno)
+ cd "plasma_wallpaper_asciiquarium"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${_pkgname}"
+ cd "$srcdir/plasma_wallpaper_asciiquarium"
cmake -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "$srcdir/${_pkgname}"
+ cd "$srcdir/plasma_wallpaper_asciiquarium"
make DESTDIR="$pkgdir/" install
}