summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStMartin812020-11-10 10:46:36 +0100
committerStMartin812020-11-10 10:47:39 +0100
commit5d59e95f5936b46f5102f96ef9ca17e4f682aef6 (patch)
treedd3f3f116500af88f22744c89d5ae3ab5746fd24 /PKGBUILD
downloadaur-5d59e95f5936b46f5102f96ef9ca17e4f682aef6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d348b08f5543
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Martin Stolpe <martin.stolpe[at]gmail{dot}com>
+# Contributor Antonio Rojas <arojas [at] archlinux.org>
+
+pkgname=plasma-wayland-protocols-git
+pkgver=r1019.314fb1c
+pkgrel=1
+pkgdesc="Plasma Specific Protocols for Wayland"
+arch=(any)
+url="https://kde.org/plasma-desktop"
+license=(LGPL)
+depends=()
+makedepends=(qt5-base extra-cmake-modules git)
+source=("git+https://invent.kde.org/libraries/plasma-wayland-protocols")
+sha256sums=('SKIP')
+provides=('plasma-wayland-protocols')
+conflicts=('plasma-wayland-protocols')
+
+pkgver() {
+ cd plasma-wayland-protocols
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S plasma-wayland-protocols
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}