summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-02 02:00:51 +0000
committerJoão Figueiredo2021-02-02 02:00:51 +0000
commitcb3c5ebe65b225b7e0007351dfe972f80b2b5ee4 (patch)
tree0feb7cda1e4084e6c8ae2f669d44a3f47224f747 /PKGBUILD
parenta0f4161deac0baf8791fe047d9f2eb9ea09cf795 (diff)
downloadaur-cb3c5ebe65b225b7e0007351dfe972f80b2b5ee4.tar.gz
Merged with official ABS plasma-workspace PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD88
1 files changed, 52 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34fa4ae234da..fa0859192435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,62 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
-pkgname=plasma-workspace-git
-pkgver=r9831.f59389a0f
-pkgrel=1
+# Merged with official ABS plasma-workspace PKGBUILD by João, 2021/01/31 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+
+pkgbase=plasma-workspace-git
+pkgname=(plasma-workspace-git plasma-wayland-session-git)
+pkgver=5.21.80_r9900.g3a1e23938
+pkgrel=2
pkgdesc='KDE Plasma Workspace'
-arch=('i686' 'x86_64')
-url='https://projects.kde.org/projects/kde/kde-workspace'
-license=('LGPL')
-depends=('qt5-tools' 'kded-git' 'libksysguard-git' 'kjsembed-git'
- 'knotifyconfig-git' 'ktexteditor-git' 'kio-extras-git' 'baloo-git' 'milou-git'
- 'libkscreen-git' 'breeze-git' 'kwin-git' 'gpsd' 'libqalculate'
- 'khelpcenter-git' 'xorg-xrdb' 'xorg-xsetroot' 'xorg-xmessage' 'xorg-xprop'
- 'prison-git' 'kxmlrpcclient-git' 'networkmanager-qt' 'kscreenlocker-git'
- 'kholidays-git')
-makedepends=('extra-cmake-modules-git' 'git' 'kdoctools-git' 'plasma-wayland-protocols-git')
-optdepends=('plasma-workspace-wallpapers: additional wallpapers')
-conflicts=('plasma-workspace' 'plasma-wayland-session' 'kdebase-workspace')
-provides=('plasma-workspace' 'plasma-wayland-session')
-source=('git+https://github.com/KDE/plasma-workspace.git')
-groups=('plasma')
-md5sums=('SKIP')
+arch=($CARCH)
+url='https://kde.org/plasma-desktop/'
+license=(LGPL)
+depends=(knotifyconfig-git libksysguard-git ktexteditor-git libqalculate-git kde-cli-tools-git appstream-qt phonon-qt5
+ xorg-xrdb xorg-xsetroot kactivitymanagerd-git kholidays-git xorg-xmessage milou-git prison-git kwin-git
+ plasma-integration-git kdelibs4support-git kpeople-git kactivities-stats-git libkscreen-git kquickcharts-git kuserfeedback-git)
+makedepends=(git extra-cmake-modules-git kdoctools-git gpsd baloo-git networkmanager-qt-git kdesignerplugin-git kinit-git plasma-wayland-protocols)
+conflicts=(${pkgbase%-git})
+provides=(${pkgbase%-git})
+groups=(plasma-git)
+source=("git+https://github.com/KDE/${pkgbase%-git}.git" kde.pam)
+sha256sums=('SKIP'
+ '00090291204baabe9d6857d3b1419832376dd2e279087d718b64792691e86739')
pkgver() {
- cd plasma-workspace
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgbase%-git}
+ _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
-prepare() {
- mkdir -p build
+build() {
+ cmake -B build -S ${pkgbase%-git} \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF
+ cmake --build build
}
-build() {
- cd build
- cmake ../plasma-workspace \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_LIBEXECDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
- make
+package_plasma-workspace-git() {
+ optdepends=('plasma-workspace-wallpapers-git: additional wallpapers'
+ 'gpsd: GPS based geolocation' 'networkmanager-qt: IP based geolocation'
+ 'kdepim-addons-git: displaying PIM events in the calendar'
+ 'appmenu-gtk-module: global menu support for GTK2 and some GTK3 applications'
+ 'qt5-virtualkeyboard: virtual keyboard support in lock screen'
+ 'baloo-git: Baloo search runner' 'discover: manage applications installation from the launcher')
+ conflicts=(plasma-workspace)
+ provides=(plasma-workspace notification-daemon)
+ backup=('etc/pam.d/kde')
+
+ DESTDIR="$pkgdir" cmake --install build
+
+ install -Dm644 "$srcdir"/kde.pam "$pkgdir"/etc/pam.d/kde
+
+ # Split plasma-wayland scripts
+ rm -r "$pkgdir"/usr/share/wayland-sessions
}
-package() {
- cd build
- make DESTDIR="$pkgdir" install
+package_plasma-wayland-session-git() {
+ pkgdesc='Plasma Wayland session'
+ depends=(plasma-workspace-git qt5-wayland kwayland-integration-git xorg-server-xwayland)
+ conflicts=(plasma-wayland-session)
+ provides=(plasma-wayland-session)
+
+ install -Dm644 build/login-sessions/plasmawayland.desktop "$pkgdir"/usr/share/wayland-sessions/plasmawayland.desktop
}