summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm-pilia2017-06-16 18:46:43 +0200
committerm-pilia2017-06-16 18:46:43 +0200
commit71917fa98cc3c3297e550893aadde33663418174 (patch)
treec5f64503bc73f73a0f08095e0ec1f098476e9870 /PKGBUILD
downloadaur-71917fa98cc3c3297e550893aadde33663418174.tar.gz
package submission
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c356e7e3c37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Martino Pilia <martino.pilia@gmail.com>
+_upstream_name=plasma-applet-ambientnoise
+pkgname=plasma5-applets-ambientnoise
+pkgver=0.1
+pkgrel=1
+pkgdesc="Plasmoid for ambient noise reproduction"
+arch=('any')
+url="https://github.com/m-pilia/plasma-applet-ambientnoise"
+license=('GPL')
+depends=('plasma-workspace')
+optdepends=('anoise-media: noise files and icons'
+ 'anoise-community-extension1: noise files and icons'
+ 'anoise-community-extension2: noise files and icons'
+ 'anoise-community-extension3: noise files and icons')
+makedepends=('extra-cmake-modules'
+ 'git')
+source=(https://github.com/m-pilia/${_upstream_name}/archive/${pkgver}.tar.gz)
+sha512sums=('c7f86a9d0fe77bc7e9a6f333427f49ccf74766aa7cca5bab126ca05134b3e8de797a518f091db0fade706d96196f7de6449af14c3fd0ae27aeffb3663dc5d6fe')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${_upstream_name}-${pkgver} -DCMAKE_INSTALL_PREFIX="${pkgdir}`kf5-config --prefix`" \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+ rm -f "$pkgdir/usr/share/icons/breeze/icon-theme.cache"
+}
+
+package() {
+ cd build
+ make install
+}