summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoriboyperson2018-03-02 12:22:04 -0700
committeriboyperson2018-03-02 12:22:04 -0700
commit58d128e3e849be3395c1eabf7c6ee533a1203a03 (patch)
tree8db19e65f3a7eb260bdafc2877a731755fc47656 /PKGBUILD
downloadaur-58d128e3e849be3395c1eabf7c6ee533a1203a03.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f11924ec1ca4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: iboyperson <iboyperson@gmail.com>
+
+pkgname=plasma5-applets-caffeine-plus
+_reponame=plasma-applet-caffeine-plus
+pkgver=1.3
+pkgrel=1
+pkgdesc="Disable screensaver and auto suspend"
+arch=('i686' 'x86_64')
+url="https://github.com/qunxyz/plasma-applet-caffeine-plus"
+makedepends=(
+ gcc
+ make
+ cmake
+ extra-cmake-modules
+ pkg-config
+)
+provides=("plasma5-applets-caffeine-plus")
+conflicts=("plasma5-applets-caffeine-plus")
+source=("https://github.com/qunxyz/plasma-applet-caffeine-plus/archive/v1.3.tar.gz")
+sha256sums=('935beb6d536e1dba81b320d9f6c27dff2d96ad85f40ea608ae7ea63ec6ea5521')
+
+prepare() {
+ cd "$srcdir/$_reponame-$pkgver"
+
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$_reponame-$pkgver"
+ cd build
+
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd "$srcdir/$_reponame-$pkgver"
+ cd build
+
+ make DESTDIR="$pkgdir/" install
+}