summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Harris2017-06-16 17:23:48 -0700
committerMike Harris2017-06-16 17:23:48 -0700
commitbeb90b455088fbb2c4b0692f57bf47bc747f839b (patch)
treefb5593a0426aa10133985749c2b11ba0ce3d301b /PKGBUILD
downloadaur-beb90b455088fbb2c4b0692f57bf47bc747f839b.tar.gz
uploading kde arch updating notification widget
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fce4f8c03497
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer Mike Harris <mike.a.harris@outlook.com>
+pkgname=plasma5-applets-kde-arch-update-notifier-git
+pkgver=1
+pkgrel=1
+pkgdesc="A KDE plasmoid for your system tray notifying you of available updates"
+url="https://github.com/I-Dream-in-Code/kde-arch-update-plasmoid"
+arch=('any')
+license=('GPL')
+depends=("fakeroot")
+makedepends=("make" "cmake" "git" "extra-cmake-modules")
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("git+https://github.com/I-Dream-in-Code/plasma5-applets-kde-arch-update-notifier-git.git")
+md5sums=("SKIP")
+build() {
+ cd ${pkgname}
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=lib -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+}
+package(){
+ cd ${srcdir}/${pkgname}/build
+ sudo make install
+
+}