summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKavya2020-04-15 14:11:27 +0530
committerKavya2020-04-15 14:11:27 +0530
commitb5c9bbc60444d54a47b7be484dc69eb773ef022d (patch)
tree564d6d78e09d2b6bfc89658a1a4957571104ea5e /PKGBUILD
downloadaur-b5c9bbc60444d54a47b7be484dc69eb773ef022d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb08a4d1955f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Kav <hello [at] properlypurple [dot] com
+
+pkgname=plasma5-applets-nx-notifications
+_pkgname=${pkgname%-git}
+_repodir=nx-notifications-applet
+pkgver=r20.aa5ae59
+pkgrel=1
+pkgdesc="Notofocation applet for NX Desktop, by Nitrux SA."
+arch=('any')
+url="https://github.com/nx-desktop/nx-notifications-applet.git"
+license=('GPL')
+depends=('plasma-workspace' 'qt5-base')
+makedepends=('git' 'extra-cmake-modules' 'kdesdk-meta')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("git+https://github.com/nx-desktop/nx-notifications-applet.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_repodir}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_repodir}"
+
+ mkdir -p build
+ cd build
+ rm -rf *
+
+ cmake -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=lib -DKDE_INSTALL_USE_QT_SYS_PATHS=ON ../
+ make
+}
+
+package() {
+ cd "${_repodir}"/build
+
+ make install DESTDIR="${pkgdir}"
+}