summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKotelnik2015-07-26 21:52:20 +0200
committerKotelnik2015-07-26 21:52:20 +0200
commit1cf06f3391293ecae62a020996f8a601e66c1b12 (patch)
treeaa976ed2cb2d020e03b0fb085d27851441341a38 /PKGBUILD
downloadaur-1cf06f3391293ecae62a020996f8a601e66c1b12.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a2cdbf09f3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Martin Kostolný <clearmartin at zoho dot com>
+
+pkgname=plasma5-applets-redshift-control-git
+_pkgname=plasma5-applets-redshift-control
+_gitpkgname=plasma-applet-redshift-control
+pkgver=r2.d16c9b5
+pkgrel=1
+pkgdesc="Plasmoid for Plasma 5 for controlling redshift."
+arch=('any')
+url="https://github.com/kotelnik/$_gitpkgname"
+license=('GPL')
+depends=('plasma-workspace' 'qt5-graphicaleffects' 'redshift')
+makedepends=('git' 'extra-cmake-modules')
+conflicts=("${_pkgname-*}")
+provides=("${_pkgname-*}")
+source=("git://github.com/kotelnik/$_gitpkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitpkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_gitpkgname}"
+
+ mkdir -p build
+ cd build
+ rm -rf *
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+}
+
+package() {
+ cd "${_gitpkgname}"/build
+
+ make install DESTDIR="${pkgdir}"
+}