summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Baum2018-06-02 12:45:55 +0200
committerDavid Baum2018-06-02 12:45:55 +0200
commit2b9d4752c73949dedd37d23b85820c35417f6c41 (patch)
treeaeec138f743b2d90183a95be10fff82e3215ccde /PKGBUILD
parent473e072dc23af831cc85db4f8ed7baa668544867 (diff)
downloadaur-2b9d4752c73949dedd37d23b85820c35417f6c41.tar.gz
update to version 1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65b4b92b46de..345c00d246dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: David Baum <david.baum@naraesk.eu>
pkgname=plasma5-applets-systemd
-pkgver=1.1.1
+pkgver=1.2.0
pkgrel=1
pkgdesc="Start and stop systemd services"
arch=('i686' 'x86_64')
url="https://github.com/naraesk/plasma-systemd"
license=('GPL3')
groups=()
-depends=()
-makedepends=('cmake' 'extra-cmake-modules' 'ki18n' 'qt5-base' 'qt5-declarative')
+depends=('plasma-workspace')
+makedepends=('cmake' 'extra-cmake-modules' 'ki18n' 'qt5-base' 'qt5-declarative' 'qt5-tools')
optdepends=()
provides=()
conflicts=()
@@ -17,9 +17,9 @@ backup=()
options=()
install=()
changelog=()
-source=('https://github.com/naraesk/plasma-systemd/archive/v1.1.1.tar.gz')
+source=('https://github.com/naraesk/plasma-systemd/archive/v1.2.0.tar.gz')
noextract=()
-md5sums=('6d94524059ef6ef77f8576a07304d307')
+md5sums=('6d0d55e7b71d6e8c0dad3de971b4e0dc')
prepare() {
cd plasma-systemd-${pkgver}
@@ -30,8 +30,8 @@ build() {
cd plasma-systemd-${pkgver}/build
export QT_SELECT=5
cmake ../ \
- -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` \
- -DLIB_INSTALL_DIR=lib \
+ -DCMAKE_INSTALL_PREFIX=`qtpaths --install-prefix` \
+ -DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DCMAKE_BUILD_TYPE=Release
make