summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkikadf2016-08-09 11:53:31 +0200
committerkikadf2016-08-09 11:53:31 +0200
commit9c74476c26ba959c97c0de3911fa241ac087b901 (patch)
tree865eddab9b389aa40551a26048edbdb6a1ee5b8d /PKGBUILD
parentfdb7ad3c20390376f23adf6ad856eacdb9832a76 (diff)
downloadaur-9c74476c26ba959c97c0de3911fa241ac087b901.tar.gz
Update to new release, use stable src
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90b6bb95c5a8..ed4bb8b99cb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: kikadf <kikadf.01@gmail.com>
pkgname=plasma5-applets-volumewin7mixer
-pkgver=r10
+pkgver=11
pkgrel=1
pkgdesc="A fork of the default volume plasmoid with a Windows 7 theme (vertical sliders)"
arch=('any')
@@ -9,25 +9,23 @@ url="https://github.com/Zren/plasma-applets/tree/master/org.kde.plasma.volumewin
license=(GPL)
depends=('plasma-workspace' 'qt5-declarative')
makedepends=('extra-cmake-modules')
-source=(git+https://github.com/Zren/plasma-applets.git
- https://raw.githubusercontent.com/kikadf/patches/master/plasma5-applets-volumewin7mixer/Add_CMakeLists.patch)
-md5sums=('SKIP'
- '78e377c969441382dd6d931688f43cbe')
-
-pkgver() {
- cd plasma-applets
- printf "r%s" "$(git rev-list --count HEAD org.kde.plasma.volumewin7mixer)"
-}
-
+source=(https://github.com/Zren/plasma-applets/archive/volumewin7mixer-$pkgver.tar.gz
+ https://raw.githubusercontent.com/kikadf/patches/master/plasma5-applets-volumewin7mixer/Add_CMakeLists.patch
+ https://raw.githubusercontent.com/kikadf/patches/master/plasma5-applets-volumewin7mixer/Enable_systray.patch)
+md5sums=('522d616869ae20e4f6df955a85b23e2a'
+ '78e377c969441382dd6d931688f43cbe'
+ 'e4d0ebac050727af6a4c2885585d5234')
prepare() {
- cd plasma-applets/org.kde.plasma.volumewin7mixer
+ cd plasma-applets-volumewin7mixer-$pkgver/org.kde.plasma.volumewin7mixer
patch -p2 -i "${srcdir}"/Add_CMakeLists.patch
+ patch -p2 -i "${srcdir}"/Enable_systray.patch
+ rm -f build
mkdir -p build
}
build() {
- cd plasma-applets/org.kde.plasma.volumewin7mixer/build
+ cd plasma-applets-volumewin7mixer-$pkgver/org.kde.plasma.volumewin7mixer/build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
@@ -36,6 +34,6 @@ build() {
}
package() {
- cd plasma-applets/org.kde.plasma.volumewin7mixer/build
+ cd plasma-applets-volumewin7mixer-$pkgver/org.kde.plasma.volumewin7mixer/build
make DESTDIR="$pkgdir" install
}