summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKotelnik2015-06-16 20:56:24 +0200
committerKotelnik2015-06-16 20:56:24 +0200
commit64aa1617bc7706cdcf06813dd6a9c26bc2e881ba (patch)
treedf73c185b2e4c2bd371785f86b7e61817c85cdce /PKGBUILD
parentcf6e1c818c99a6e90854880f15603540f3d7a992 (diff)
downloadaur-64aa1617bc7706cdcf06813dd6a9c26bc2e881ba.tar.gz
PKGBUILD fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26bc783adfe9..2f4bfe8b41de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Martin Kostolný <clearmartin at zoho dot com>
pkgname=plasma5-applets-weather-widget-git
-_pkgname=plasma-applet-weather-widget
+_pkgname=plasma5-applets-weather-widget
+_gitpkgname=plasma-applet-weather-widget
pkgver=r15.6241400
pkgrel=1
pkgdesc="Plasmoid for Plasma 5. Shows weather information from yr.no server."
arch=('any')
-url="https://github.com/kotelnik/$_pkgname"
+url="https://github.com/kotelnik/$_gitpkgname"
license=('GPL')
depends=('plasma-workspace' 'qt5-graphicaleffects')
makedepends=('git' 'extra-cmake-modules')
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}")
-source=("git://github.com/kotelnik/$_pkgname.git")
+conflicts=("${_pkgname-*}")
+provides=("${_pkgname-*}")
+source=("git://github.com/kotelnik/$_gitpkgname.git")
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${_gitpkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${_pkgname}"
+ cd "${_gitpkgname}"
mkdir -p build
cd build
@@ -35,7 +36,7 @@ build() {
}
package() {
- cd "${_pkgname}"/build
+ cd "${_gitpkgname}"/build
make install DESTDIR="${pkgdir}"
}