summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKotelnik2015-06-15 19:27:37 +0200
committerKotelnik2015-06-15 19:27:37 +0200
commitcf6e1c818c99a6e90854880f15603540f3d7a992 (patch)
tree19df7e941f2ead06738fe464c141bb11d7810cf2 /PKGBUILD
downloadaur-cf6e1c818c99a6e90854880f15603540f3d7a992.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26bc783adfe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Martin Kostolný <clearmartin at zoho dot com>
+
+pkgname=plasma5-applets-weather-widget-git
+_pkgname=plasma-applet-weather-widget
+pkgver=r15.6241400
+pkgrel=1
+pkgdesc="Plasmoid for Plasma 5. Shows weather information from yr.no server."
+arch=('any')
+url="https://github.com/kotelnik/$_pkgname"
+license=('GPL')
+depends=('plasma-workspace' 'qt5-graphicaleffects')
+makedepends=('git' 'extra-cmake-modules')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+source=("git://github.com/kotelnik/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+
+ mkdir -p build
+ cd build
+ rm -rf *
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+}
+
+package() {
+ cd "${_pkgname}"/build
+
+ make install DESTDIR="${pkgdir}"
+}