summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormelvyn22022-06-27 22:26:26 -0700
committermelvyn22022-06-27 22:26:26 -0700
commit5c5db7c1946eb63ad41f4ce26bc0bdfb0fceeddc (patch)
tree69fce82a882b13ff0ea1ffcf899d06bf75606087 /PKGBUILD
downloadaur-5c5db7c1946eb63ad41f4ce26bc0bdfb0fceeddc.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6b6741584ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: melvyn2 <melvyn2 at brcok dot tk>
+pkgname=plasma5-shader-wallpaper
+pkgver=r67.d108ed7
+pkgrel=1
+pkgdesc="Plasma animated shader wallpaper plugin"
+arch=(any)
+url="https://github.com/y4my4my4m/kde-shader-wallpaper"
+license=(GPL)
+depends=(plasma-desktop)
+makedepends=('git')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/kde-shader-wallpaper"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/plasma/wallpapers/online.knowmad.shaderwallpaper"
+ cp "${srcdir}/kde-shader-wallpaper/metadata.desktop" "${pkgdir}/usr/share/plasma/wallpapers/online.knowmad.shaderwallpaper"
+ cp -r "${srcdir}/kde-shader-wallpaper/contents" "${pkgdir}/usr/share/plasma/wallpapers/online.knowmad.shaderwallpaper"
+}