summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorS Garnica2023-11-29 13:29:27 +0100
committerS Garnica2023-11-29 13:29:27 +0100
commitb449d32d68d607e8e6faf4a235273d93d4710968 (patch)
tree9eee15fc3caf8ac4e010868426990d7a8cd77935 /PKGBUILD
parente935229bf312695d66ccb43900adc72bb241447b (diff)
downloadaur-platformio-git.tar.gz
Updated deps, thanks JohnTheCF
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 31 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 281e219ebcea..c29661342825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,44 @@
pkgname=platformio-git
_pkgname=platformio-core
-pkgver=v6.1.10.r12.g00409fc0
+pkgver=v6.1.11.r20.gb238c55e
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="http://platformio.org/"
license=('GPL')
provides=('platformio')
-depends=('python-setuptools'
- 'python-bottle'
- 'python-click'
- 'python-colorama'
- 'python-pyserial'
- 'python-requests'
- 'python-semantic-version'
- 'python-tabulate'
- 'python-pyelftools'
- 'python-marshmallow')
+depends=(
+ 'python'
+ 'python-bottle'
+ 'python-click'
+ 'python-colorama'
+ 'python-pyserial'
+ 'python-requests'
+ 'python-semantic-version'
+ 'python-tabulate'
+ 'python-pyelftools'
+ 'python-marshmallow'
+ 'python-zeroconf'
+ 'python-aiofiles'
+ 'python-ajsonrpc'
+ 'python-starlette'
+ 'python-wsproto'
+ 'uvicorn'
+)
optdepends=('energia: For MSP430 based projects'
- 'arduino: For Arduino based projects')
-makedepends=('git')
+ 'arduino: For Arduino based projects'
+ 'platformio-core-udev: Udev rules for PlatformIO supported boards/devices'
+ 'python-click-completion: for shell completions'
+ 'python-shellingham: for shell completions'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
source=('git+https://github.com/platformio/platformio-core.git')
md5sums=('SKIP')