summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-11-20 17:08:45 +0000
committerHans-Nikolai Viessmann2016-11-20 17:08:45 +0000
commitcd2a0875db551f599d6403836172bafb9f31059b (patch)
tree192b6bcd43b80509976294ee85c28c5438deabcd /PKGBUILD
downloadaur-cd2a0875db551f599d6403836172bafb9f31059b.tar.gz
Initial commit
Already had to fix the install script...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cc3f2c43cbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+
+pkgname=plex-media-player-standalone-service
+pkgver=1.0
+pkgrel=2
+pkgdesc="Systemd service and user to run PMP in stand-alone mode"
+arch=('x86_64' 'i686')
+url="https://github.com/hv15/plex-media-player-standalone-service"
+license=('GPL')
+depends=('systemd' 'xorg-server' 'xorg-xinit' 'plex-media-player' 'polkit')
+install="${pkgname}.install"
+source=("https://github.com/hv15/${pkgname}/archive/${pkgver}.tar.gz"
+ "https://github.com/hv15/${pkgname}/releases/download/${pkgver}/${pkgver}.tar.gz.sig")
+sha256sums=('a231685b9eed6ccfb0eefcf40b89b823ff8d33954c4daa2d68ed386ac73e172b'
+ 'SKIP')
+validgpgkeys=('0x9062A1BF982A2B64')
+
+package() {
+ install -Dm644 "$srcdir/$pkgname-$pkgver/plexmediaplayer.service" \
+ "$pkgdir/usr/lib/systemd/system/plexmediaplayer.service"
+ install -dm 700 "$pkgdir"/var/lib/plexmediaplayer
+ chown 1420:1420 "$pkgdir"/var/lib/plexmediaplayer
+}