summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfzerorubigd2021-01-17 14:26:02 +0100
committerfzerorubigd2021-01-17 14:31:57 +0100
commit0aeace9f8b9f6b14531430f2f68584318041a3ee (patch)
treedb49a0306167fc1be74a2bb4978d66763f97071e /PKGBUILD
downloadaur-0aeace9f8b9f6b14531430f2f68584318041a3ee.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff5b892542f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: fzerorubigd <fzero at rubi dot gd>
+# Contributor: Kyle McNally <kyle@kmcnally.net>
+# Contributor: Matt Aitchison
+
+pkgname=('plex-sub-zero-git')
+pkgver=2.6.5.3247.r0.g6b918be7
+pkgrel=1
+pkgdesc='Subtitles for Plex, as good you would expect them to be'
+arch=('any')
+url='https://github.com/pannal/Sub-Zero.bundle'
+license=('MIT')
+options=('!strip')
+depends=('python' 'plex-media-server')
+source=("git://github.com/pannal/Sub-Zero.bundle.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Sub-Zero.bundle"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+
+}
+
+package() {
+ install -D -m644 "${srcdir}/Sub-Zero.bundle/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir -p "${pkgdir}/var/lib/plex/Plex Media Server/Plug-ins/Sub-Zero.bundle"
+ cp -r "${srcdir}/Sub-Zero.bundle"/* "${pkgdir}/var/lib/plex/Plex Media Server/Plug-ins/Sub-Zero.bundle/"
+}