summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathaniel Chin2021-03-29 21:32:55 +0800
committerNathaniel Chin2021-04-06 20:12:12 +0800
commitb888dcbad69d477722c46e3f6f181dc00de8d501 (patch)
tree99b33dd3e405d9bcdfeb392d3c193a2138483c12 /PKGBUILD
parente9e72fe3cbdc8de198c8d4d43b32e5f5a8e6c847 (diff)
downloadaur-b888dcbad69d477722c46e3f6f181dc00de8d501.tar.gz
fix up pkgbuild
.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28d073b67d67..9128705925bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+# Maintainer: Nathaniel Chin <thegamingorangutans+aur at gmail.com>
+# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
-_pkgname=plotbitrate
-pkgname=$_pkgname-git
-pkgver=1.0.7.1.r1.g5a5665b
+pkgname=plotbitrate-git
+pkgver=1.0.7.1.r3.ga092d99
pkgrel=1
pkgdesc="a script for plotting the bitrate of an audio or video stream over time"
arch=('any')
@@ -10,22 +10,17 @@ url="https://github.com/zeroepoch/plotbitrate"
license=('BSD')
depends=('python-matplotlib' 'python-pyqt5' 'ffmpeg')
makedepends=('git' 'python-setuptools')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$_pkgname::git+$url.git")
+source=("git+https://github.com/zeroepoch/plotbitrate.git")
md5sums=('SKIP')
+provides=('python-plotbitrate-git')
+conflicts=('python-plotbitrate-git')
pkgver() {
- cd "$_pkgname"
+ cd "plotbitrate"
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
package() {
- cd "$_pkgname"
- install -Dm755 "$_pkgname.py" "$pkgdir/usr/bin/$_pkgname"
- mkdir -p "$pkgdir/usr/lib/python$(python3 -V | awk -F. -v OFS=. '{print $1, $2}' | awk '{print $2}')/site-packages/"
- mv frame "$pkgdir/usr/lib/python$(python3 -V | awk -F. -v OFS=. '{print $1, $2}' | awk '{print $2}')/site-packages/"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/plotbitrate"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}
-
-# vim:set ts=2 sw=2 et: