summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2021-01-20 02:59:20 +0100
committerPellegrino Prevete2021-01-20 02:59:20 +0100
commit784745c4b7e86f54c27efd7e8dd6d05a249f8897 (patch)
treebc3226442ef6f79589e89ae9f144f8152d436172 /PKGBUILD
parent2adf67ec7e090c3f68441efde15cd6369866e34a (diff)
downloadaur-784745c4b7e86f54c27efd7e8dd6d05a249f8897.tar.gz
Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b066907f1b7..f60ac70bcf88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: twa022 <twa022 at gmail dot com>
# Contributor: Carl George < arch at cgtx dot us >
+# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
pkgname=plotinus
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A searchable command palette for GTK3 applications'
-arch=('i686' 'x86_64')
+arch=('any')
url='https://github.com/p-e-w/plotinus'
license=('GPL3')
depends=('gtk3')
makedepends=('vala' 'cmake')
-source=("https://github.com/p-e-w/plotinus/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+source=("git+https://github.com/p-e-w/plotinus#tag=v$pkgver"
"plotinus.sh")
-sha256sums=('6d814d19e6868f3d52ecd923ad6da465c632bb5dfcdc97c5245ad107e582c33b'
+sha256sums=('SKIP'
'96fad14ace388edf164b5158adb507765b2bd1fe5c9435c41081ffa8ac2cec11')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
cmake .
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
install -Dm755 --target-directory "${pkgdir}"/usr/lib libplotinus.so
install -Dm644 --target-directory "${pkgdir}"/etc/profile.d "${srcdir}"/plotinus.sh
}