summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenoit Pierre2022-02-24 11:23:25 +0100
committerBenoit Pierre2022-02-24 11:23:25 +0100
commitd202ff6df66635891a72edd076e175e5776c9f5b (patch)
tree1f02f2cfd26a05ea82e9a392896f03089e5f4ce9 /PKGBUILD
parentb31de37570010731a2b3da5b1f27d07842492414 (diff)
downloadaur-d202ff6df66635891a72edd076e175e5776c9f5b.tar.gz
switch to `python-installer` for installing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f436808c4fb..ca0f50166684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ depends=(
)
makedepends=(
'python-build'
- 'python-install'
+ 'python-installer'
)
url="https://github.com/benoit-pierre/plover_plugins_manager"
_pkgdist="$pkgname-$pkgver"
@@ -38,10 +38,8 @@ build() {
package() {
cd "$_pkgdist"
- python -m install --destdir="$pkgdir" --optimize=1 dist/*.whl
+ python -m installer --destdir="$pkgdir" --compile-bytecode=1 dist/*.whl
chmod og+rX -R "$pkgdir"
- # Workaround `python-install` bug: console scripts missing execute permissions...
- chmod +x "$pkgdir/usr/bin"/*
}
# vim:set sw=2 sts=2 et: