summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Unruh2021-08-18 00:51:14 +0200
committerKonstantin Unruh2021-08-18 00:51:14 +0200
commit418aed1858ae5e20301bd9b222d589d0f37b01a0 (patch)
tree46bc88455f467e790b795b918bf200bcbabcaae8 /PKGBUILD
parentee173abca446b8d5b0fc332c65a0014a3acdd689 (diff)
downloadaur-418aed1858ae5e20301bd9b222d589d0f37b01a0.tar.gz
replace old non-funcitonal pluma-plugins with official pluma-plugins
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 20 insertions, 55 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3df249099656..0348ae7ca2a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,27 @@
-# Mantainer: 3ED <krzysztof1987 at gmail>
-# Contributor: adlerweb <get on aur>
-
-# 2017-04-30 facts:
-# - plugins works only with 1.16 version
-# - python plugins works only with gtk2 version
-# more info:
-# https://github.com/yselkowitz/pluma-plugins/issues/6
-
-_pkgname=pluma-plugins
-pkgname=${_pkgname}
-pkgver=1.16.0
-_cygrel=1
-epoch=1
+# Maintainer: Konstantin Unruh <freaxmate@protonmail.com>
+pkgname=pluma-plugins
+pkgver=1.26.0
pkgrel=1
-pkgdesc="extra plugins for pluma text editor"
-arch=('i686' 'x86_64')
-url="http://mate-desktop.org/"
-license=('GPL')
-depends=('pluma-1.16<=1.16.9999' 'mate-common')
-conflicts=("${_pkgname}-gtk2")
-source=("http://cygwin.cathedral-networks.org/x86/release/${_pkgname}/${_pkgname}-${pkgver}-${_cygrel}-src.tar.xz")
-noextract=("${_pkgname}-${pkgver}-${_cygrel}-src.tar.xz")
-sha256sums=('e4ae4684c074cae81b9f05cc2ea034195e3a1dadff64f2efcb7c362d780a8a1d')
-
-# gtk2 uncomment:
-#pkgname=${_pkgname}-gtk2
-#depends=('pluma-gtk2<=1.16.9999' 'mate-common')
-#conflicts=("${_pkgname}")
-
-prepare() {
- msg2 'Extracting archive...'
- bsdtar \
- --extract \
- --xz \
- --file "${_pkgname}-${pkgver}-${_cygrel}-src.tar.xz" \
- --include '^pluma-plugins-*.src/pluma-plugins-*.tar.gz$' \
- --to-stdout \
- | bsdtar \
- --extract \
- --gzip \
- --file -
-
- msg2 'Autogen the configuration tool...'
- cd "${_pkgname}-${pkgver}"
- PYTHON=/usr/bin/python2 ./autogen.sh \
- --prefix="/usr" \
- --sbindir="/usr/bin" \
- --libexecdir="/usr/lib/${_pkgname}" \
- --with-plugins=all \
- --enable-python
-}
+pkgdesc="A set of plugins for Pluma"
+arch=('any')
+url="https://github.com/mate-desktop/$pkgname"
+license=('GPL2')
+depends=('pluma>=1.26.0')
+makedepends=('autoconf-archive' 'gtksourceview4' 'make' 'mate-common' 'yelp-tools')
+optdepends=('vte3: to use the embedded terminal'
+ 'dbus-python: to use the synctex plugin with atril'
+ 'atril: to use the synctex plugin with atril')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mate-desktop/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('d9075281121fedce74eeda752d012f8b86407a5e1c89b25b4c370bb07c50f5dc30e74e11b6aa5333fcc401d45d220b801eb8dedf0650ae9aa16d9af271cac80e')
build() {
- cd "${_pkgname}-${pkgver}"
- make
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ make
}
package() {
- cd "${_pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
}
+