summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHector Mtz-Seara2019-07-23 18:52:27 +0200
committerHector Mtz-Seara2019-07-23 18:52:27 +0200
commit6e8ccb4c0c1fc4851b26a598ae09c82c035f5b99 (patch)
treea66770223bd2ef039b5b7063dcf2d7a247ded1f9 /PKGBUILD
parent3aca3c21c81cd5f8ffe18f44cc2f7d4cfe568921 (diff)
downloadaur-6e8ccb4c0c1fc4851b26a598ae09c82c035f5b99.tar.gz
Compiled with gcc8 to avoid library issues with gromacs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fa27c9cc1c8..979d9201d3cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=plumed
pkgver=2.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines."
url="http://www.plumed.org/"
license=("GPL")
arch=(i686 x86_64)
-depends=('lapack' 'zlib' 'gsl' 'netcdf')
+depends=('lapack' 'zlib' 'gsl' 'netcdf' 'gcc8')
optdepends=('vmd-molfile-plugins: Add capability to read vmd compatible trajectories')
makedepends=('vim')
provides=('plumed')
@@ -17,6 +17,10 @@ source=( https://github.com/plumed/plumed2/releases/download/v${pkgver}/plumed-$
sha1sums=('5f0944c126e00e27601aca841a94dd397fd33dc6')
#options=(!buildflags)
+#Using gcc8 as compiler due to linking problems with gromacs-plumed
+export CC=gcc-8
+export CXX=g++-8
+
# Extend support for trajectory analysis to formats undestood by vmd
if [ -d "/usr/lib/vmd-molfile-plugins" ]; then
msg2 "Adding vmd-molfile plugin support"