summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrobot Viktor2019-04-10 19:29:59 +0300
committerDrobot Viktor2019-04-10 19:29:59 +0300
commit015b12f19b240722e93d5898f0d917f775c2fc72 (patch)
treeeda61be49cf391b44105a14e87abdd5e6624dc41 /PKGBUILD
parent260ec0e85469063fda86fd4982cf8c6d63877f9d (diff)
downloadaur-015b12f19b240722e93d5898f0d917f775c2fc72.tar.gz
Fixed deps. Added vmd-molfile-plugin support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbbf7aba0675..e33147938430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,25 @@
pkgname=plumed-mpi
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines (with MPI support)"
url="http://www.plumed-code.org/"
license=("GPL")
arch=(i686 x86_64)
depends=('lapack' 'zlib' 'gsl' 'openmpi')
-makedepends=()
+optdepends=('vmd-molfile-plugins: Add capability to read vmd compatible trajectories')
+makedepends=('vim')
provides=('plumed')
source=( https://github.com/plumed/plumed2/releases/download/v${pkgver}/plumed-${pkgver}.tgz)
sha1sums=('0b93fcd39a4e5b1b81e24657438e3831faa53753')
+# Extend support for trajectory analysis to formats undestood by vmd
+if [ -d "/usr/lib/vmd-molfile-plugins" ]; then
+ msg2 "Adding vmd-molfile plugin support"
+ LDFLAGS+=" -L/usr/lib/vmd-molfile-plugins -lnetcdf"
+ CPPFLAGS+=" -I/usr/include/vmd-molfile-plugins"
+fi
+
build() {
cd ${srcdir}/${pkgname%-mpi}-${pkgver}
./configure --prefix=/opt/${pkgname} --enable-mpi