summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrobot Viktor2019-01-31 16:39:18 +0300
committerDrobot Viktor2019-01-31 16:39:18 +0300
commit260ec0e85469063fda86fd4982cf8c6d63877f9d (patch)
tree2050cd7f8de4de9861248abccc748a6b55b71251 /PKGBUILD
downloadaur-260ec0e85469063fda86fd4982cf8c6d63877f9d.tar.gz
MPI version release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbbf7aba0675
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=plumed-mpi
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines (with MPI support)"
+url="http://www.plumed-code.org/"
+license=("GPL")
+arch=(i686 x86_64)
+depends=('lapack' 'zlib' 'gsl' 'openmpi')
+makedepends=()
+provides=('plumed')
+source=( https://github.com/plumed/plumed2/releases/download/v${pkgver}/plumed-${pkgver}.tgz)
+sha1sums=('0b93fcd39a4e5b1b81e24657438e3831faa53753')
+
+build() {
+ cd ${srcdir}/${pkgname%-mpi}-${pkgver}
+ ./configure --prefix=/opt/${pkgname} --enable-mpi
+ make
+}
+
+
+package() {
+ cd ${srcdir}/${pkgname%-mpi}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}