summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrobot Viktor2019-08-13 16:39:29 +0300
committerDrobot Viktor2019-08-13 16:39:29 +0300
commit63f099b1be3f250b8a3eb7feccb9b685584a7e68 (patch)
tree45b73aba427a72b7d2fca2120d3b298ccaa506cc /PKGBUILD
parent796e3308289c259c9899dce10e70999de52dc362 (diff)
downloadaur-63f099b1be3f250b8a3eb7feccb9b685584a7e68.tar.gz
Bump to 2.5.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acc22a8540a4..958dda2e72e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=plumed-mpi
-pkgver=2.5.1
-pkgrel=3
+pkgver=2.5.2
+pkgrel=1
pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines (with MPI support)"
-url="http://www.plumed-code.org/"
+url="http://www.plumed.org/"
license=("GPL")
arch=(i686 x86_64)
-depends=('lapack' 'zlib' 'gsl' 'openmpi')
+depends=('lapack' 'zlib' 'gsl' 'openmpi' 'netcdf')
optdepends=('vmd-molfile-plugins: add capability to read vmd compatible trajectories'
'xdrfile: GROMACS trajectory format support'
-# 'python-setuptools: Python module support'
-# 'cython: Python module support'
+ 'python-setuptools: Python module support'
+ 'cython: Python module support'
'graphviz: diagrams in manual')
makedepends=('vim')
source=( https://github.com/plumed/plumed2/releases/download/v${pkgver}/plumed-${pkgver}.tgz)
-sha1sums=('e3af8b82c08781b738137727e0b30c06cef7179f')
+sha1sums=('5f0944c126e00e27601aca841a94dd397fd33dc6')
-# Extend support for trajectory analysis to formats undestood by vmd
+# Extend support for trajectory analysis to formats understood by vmd (thx hseara!)
if [ -d "/usr/lib/vmd-molfile-plugins" ]; then
msg2 "Adding vmd-molfile plugin support"
LDFLAGS+=" -L/usr/lib/vmd-molfile-plugins -lnetcdf"
@@ -26,7 +26,7 @@ fi
build() {
cd ${srcdir}/${pkgname%-mpi}-${pkgver}
- ./configure --prefix=/usr --enable-mpi --program-suffix=-mpi --disable-python
+ ./configure --prefix=/usr --enable-mpi --program-suffix=-mpi
make
}