summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2020-05-26 00:11:34 +0300
committerViktor Drobot2020-05-26 00:11:34 +0300
commit9e8165dcadd472c97ce83b7dba35b788fa7f0fcb (patch)
treee930da7e2756e2353325b4b5591af980400271a7 /PKGBUILD
parentc1675061af9fc5aabde3ad75e5a6caacb87230f6 (diff)
downloadaur-9e8165dcadd472c97ce83b7dba35b788fa7f0fcb.tar.gz
Use openmpi-gcc8 now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80e10a7ea6f2..3caeee194d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=plumed-mpi
pkgver=2.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines (with MPI support)"
url="http://www.plumed.org/"
-license=("GPL")
+license=(GPL)
arch=(i686 x86_64)
-depends=('lapack' 'zlib' 'gsl' 'openmpi' 'netcdf')
+depends=(lapack zlib gsl gcc8 openmpi-gcc8 netcdf)
optdepends=('vmd-molfile-plugins: add capability to read vmd compatible trajectories'
'xdrfile: GROMACS trajectory format support'
'python-setuptools: Python module support'
@@ -15,13 +15,12 @@ optdepends=('vmd-molfile-plugins: add capability to read vmd compatible trajecto
'graphviz: diagrams in manual'
'gawk: partial tempering support'
'plumed-patches: extra engine patches')
-makedepends=('vim')
+makedepends=(vim)
source=(https://github.com/plumed/plumed2/releases/download/v${pkgver}/plumed-${pkgver}.tgz)
sha1sums=('aa9e0eb5ff85a778f0ac4c0637e10a499f36b107')
prepare() {
# Extend support for trajectory analysis to formats understood by vmd (thx hseara!)
-
if [ -d "/usr/lib/vmd-molfile-plugins" ]; then
msg2 "Adding vmd-molfile plugin support"
export LDFLAGS="$LDFLAGS -L/usr/lib/vmd-molfile-plugins -lnetcdf"
@@ -32,11 +31,10 @@ prepare() {
build() {
cd ${srcdir}/${pkgname%-mpi}-${pkgver}
- ./configure --prefix=/usr --enable-mpi --enable-asmjit --program-suffix=-mpi
+ ./configure CC=mpicc CXX=mpic++ --prefix=/usr --enable-mpi --enable-asmjit --enable-modules=all --program-suffix=-mpi
make
}
-
package() {
cd ${srcdir}/${pkgname%-mpi}-${pkgver}