summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew McGinn2019-10-22 14:03:08 +0200
committerMatthew McGinn2019-10-22 14:03:16 +0200
commit174270d78894e59627f26b30899b81e7c72a5b7e (patch)
tree8acdd03c068d1ac0da81c2a08449a382b026fa5f /PKGBUILD
downloadaur-174270d78894e59627f26b30899b81e7c72a5b7e.tar.gz
initial commit
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15653d91e154
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Matthew McGinn <mamcgi@gmail.com>
+pkgname=ply-git
+_pkgname=ply
+pkgrel=1
+pkgver=r322.aa5b9ac
+pkgdesc="A light-weight dynamic tracer for Linux"
+arch=('x86_64')
+url="https://github.com/iovisor/ply"
+license=('BSD')
+provides=('ply')
+source=("git+https://github.com/iovisor/${_pkgname}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ set -o pipefail
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ ./autogen.sh # to generate the configure script
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}/" install
+}