summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTaijian2020-08-20 23:20:43 +0200
committerTaijian2020-08-20 23:20:43 +0200
commita6f9735fc5632931e8fe83c43bba63d631c66f23 (patch)
treedd4ba187891ac3532b99b9b459c853fb9f699e68 /PKGBUILD
parentfa78a8a5bf25c7d84f5ca5f46ed09f754cbbf0b0 (diff)
downloadaur-a6f9735fc5632931e8fe83c43bba63d631c66f23.tar.gz
use upstream DM service files for DMs that support plymouth ootb - non-breaking change with symlinks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5210744ec2bd..492b7593ae32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=plymouth
pkgver=0.9.5
-pkgrel=3
+pkgrel=4
pkgdesc="A graphical boot splash screen with kernel mode-setting support"
url="https://www.freedesktop.org/wiki/Software/Plymouth/"
arch=('i686' 'x86_64')
@@ -26,11 +26,8 @@ source=("https://gitlab.freedesktop.org/${pkgname}/${pkgname}/-/archive/${pkgver
'arch-logo.png'
'plymouth.encrypt_hook'
'plymouth.encrypt_install'
- 'gdm-plymouth.service'
'lxdm-plymouth.service'
- 'lightdm-plymouth.service'
'slim-plymouth.service'
- 'sddm-plymouth.service'
'plymouth-deactivate.service'
'plymouth-start.service.in.patch'
'plymouth-start.path'
@@ -45,11 +42,8 @@ sha256sums=('55a461003ece0a4daeffb8b7ac2178977c5ce024a7e688d24f6d2230465b50ba'
'de4369ad5a5511b684305e3a882c2c56204696514ea8ccdb556dd656eca062e7'
'7afa97d21444cbac7a6213edda09d9fa73ecbef1a6cea1e745f56669760c6120'
'373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a'
- '0fabb974c1a301da000d5c4b9eea224ba508e577d3a6a798b67b94d4d54af255'
'06b31999cf60f49e536c7a12bc1c4f75f2671feb848bf5ccb91a963147e2680d'
- '86d0230d9393c9d83eb7bb430e6b0fb5e3f32e78fcd30f3ecd4e6f3c30b18f71'
'9b5534921c5bf92a9285ba53b323209e812145c204ac5fed6899b7aad78300ef'
- '46b1c4d6c41a888e55d05d21996c4381019e91b490ed13e216b229e264a56648'
'3b17ed58b59a4b60d904c60bba52bae7ad685aa8273f6ceaae08a15870c0a9eb'
'3a46f7faced877a913506d59757f0af60ad3d5f0bc365c56ed7ecc7aef75c5eb'
'ce3d62f4c5a1b5c0ccadd15406c7430251d1a42b232721bfbfc747da1b13e3ff'
@@ -107,9 +101,13 @@ package() {
install -Dm644 "$srcdir/plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/plymouth"
install -Dm644 "$srcdir/sd-plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/sd-plymouth"
- for i in {gdm,sddm,lxdm,slim,lightdm}-plymouth.service; do
+ for i in {lxdm,slim}-plymouth.service; do
install -Dm644 "$srcdir/$i" "$pkgdir/usr/lib/systemd/system/$i"
done
+
+ for i in {gdm,sddm,lightdm}; do
+ ln -s "/usr/lib/systemd/system/$i.service" "$pkgdir/usr/lib/systemd/system/$i-plymouth.service"
+ done
install -Dm644 "$srcdir/plymouth-deactivate.service" "$pkgdir/usr/lib/systemd/system/plymouth-deactivate.service"
install -Dm644 "$srcdir/plymouth-start.path" "$pkgdir/usr/lib/systemd/system/plymouth-start.path"