summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTaijian2022-09-04 17:36:49 +0200
committerTaijian2022-09-04 17:36:49 +0200
commitfc540eeaddc3e7956454111c3aecc717166e992a (patch)
treee7b05eb43a3133c5c8bce23d31bf591132fda149 /PKGBUILD
parent61629bfdc373e157c2188f51fd4b1b550f5092ac (diff)
downloadaur-fc540eeaddc3e7956454111c3aecc717166e992a.tar.gz
add patch to fix build failure & fix font dependencies for initramfs generation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72a686843405..4bcb52c02a99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=plymouth
pkgver=22.02.122
-pkgrel=1
+pkgrel=2
pkgdesc="A graphical boot splash screen with kernel mode-setting support"
url="https://www.freedesktop.org/wiki/Software/Plymouth/"
arch=('i686' 'x86_64')
@@ -14,13 +14,10 @@ license=('GPL')
depends=('libdrm' 'pango' 'systemd')
makedepends=('docbook-xsl')
-optdepends=('ttf-dejavu: For true type font support'
- 'xf86-video-fbdev: Support special graphic cards on early startup'
- 'cantarell-fonts: True Type support for BGRT theme')
+optdepends=('cantarell-fonts: For true type font support'
+ 'xf86-video-fbdev: Support special graphic cards on early startup')
backup=('etc/plymouth/plymouthd.conf')
-options=('!libtool' '!emptydirs')
-
source=("https://gitlab.freedesktop.org/${pkgname}/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
'arch-logo.png'
'plymouth.encrypt_hook'
@@ -35,6 +32,7 @@ source=("https://gitlab.freedesktop.org/${pkgname}/${pkgname}/-/archive/${pkgver
'plymouth-quit.service.in.patch'
'plymouth-update-initrd.patch'
'plymouthd.conf.patch'
+ 'ply-utils.c.patch'
)
sha256sums=('8921cd61a9f32f5f8903ceffb9ab0defaef8326253e1549ef85587c19b7f2ab6'
@@ -46,17 +44,20 @@ sha256sums=('8921cd61a9f32f5f8903ceffb9ab0defaef8326253e1549ef85587c19b7f2ab6'
'c39f526f7e99173bc8f012900f53257537a25e2d8c19e23df630f1fe9a7627ba'
'3b17ed58b59a4b60d904c60bba52bae7ad685aa8273f6ceaae08a15870c0a9eb'
'2a80e2cad8de428358647677afa166219589d3338c5f94838146c804a29e2769'
- 'd2201253d9f4a1f7e556e60a04401237273a4577e157a8c4471d5c81bff88ccd'
- 'd254f3d01631024ed4563d39fcaa631b0ace097faf7ed05de382859ccfa48a08'
+ 'fe425b7aa1e17b32267b4d46a0157ed6943763c77598e183df75e2efafd07efd'
+ '9f34e5efb3a4ecdb2095d9f0f5f7a01f1033b2ba1fcbf172dbaafc2c37043b03'
'dec28b86ddea93704f8479d33e08f81cd7ff4ccaad57e9053c23bd046db2278a'
'74908ba59cea53c6a9ab67bb6dec1de1616f3851a0fd89bb3c157a1c54e6633a'
- '71d34351b4313da01e1ceeb082d9776599974ce143c87e93f0a465f342a74fd2')
+ '71d34351b4313da01e1ceeb082d9776599974ce143c87e93f0a465f342a74fd2'
+ '1bd7693d1e135fe9e22a03f7635309e2ae616e952665d9774eb5ca4d82718e1b')
prepare() {
cd "$srcdir"/${pkgname}-${pkgver}
patch -p1 -i $srcdir/plymouth-update-initrd.patch
patch -p1 -i $srcdir/plymouth-quit.service.in.patch
patch -p1 -i $srcdir/plymouthd.conf.patch
+ # apply upstream patch
+ patch -p1 -i $srcdir/ply-utils.c.patch
}
build() {
@@ -106,4 +107,7 @@ package() {
install -Dm644 "$srcdir/plymouth-deactivate.service" "$pkgdir/usr/lib/systemd/system/plymouth-deactivate.service"
install -Dm644 "$pkgdir/usr/share/plymouth/plymouthd.defaults" "$pkgdir/etc/plymouth/plymouthd.conf"
+
+ # remove unused scripts
+ rm -rf "$pkgdir"/usr/lib/plymouth/plymouth-{generate,populate}-initrd
}