summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergey Slipchenko2019-01-24 22:39:29 +0300
committerSergey Slipchenko2019-01-24 22:40:08 +0300
commit605ebb9df305122bb57407edd177a3fa07bdea49 (patch)
treea3e016a601ed9809e7ebc6e13d19cacfebf2295d /PKGBUILD
parent91030bc72024fe5a6d9b8f57e433a959ac29d7ef (diff)
downloadaur-605ebb9df305122bb57407edd177a3fa07bdea49.tar.gz
Do not patch systemd unit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21118262d5e4..01b9d7727daa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sergey Slipchenko <faergeek@gmail.com>
pkgname=plymouth-lite-rbp-git
pkgver=r10.76e20e8
-pkgrel=1
+pkgrel=2
pkgdesc="Plymouth-lite patched and ready for Raspberry Pi"
arch=('armv7h')
url="https://github.com/T4d3o/Plymouth-lite"
@@ -9,31 +9,28 @@ license=('GPL2')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('plymouth-lite-rbp::git+https://github.com/T4d3o/Plymouth-lite.git'
- '01-change-systemd-unit.patch' 'initcpio_hook' 'initcpio_install')
+source=('git+https://github.com/T4d3o/Plymouth-lite.git'
+ 'initcpio_hook'
+ 'initcpio_install')
md5sums=('SKIP'
- '709d24411c2fcd62b2eccbfc98010b25'
'86dcab222ab4be45fc96d2792ff91809'
'e13f4e22ee8e28eef85028c9307bfc3f')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd Plymouth-lite
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -Np1 -i "$srcdir/01-change-systemd-unit.patch"
-}
-
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd Plymouth-lite
+
make
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd Plymouth-lite
+
make DESTDIR="$pkgdir/" install
mkdir -p $pkgdir/usr/lib/systemd/system/
install -Dm0644 systemd/* $pkgdir/usr/lib/systemd/system/