summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsataa2023-09-09 20:58:30 -0400
committersataa2023-09-09 20:58:30 -0400
commit584569c19e4e40e08f18bd0989db6115e52306dd (patch)
treedeff46bf93b48c80cecdc03455f9533eea2dcc23 /PKGBUILD
downloadaur-584569c19e4e40e08f18bd0989db6115e52306dd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92d6744c1c2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: sataa <brodmoran[at]gmail[dot]com>
+
+_theme="arch-circle"
+_pkgname="plymouth-theme-$_theme"
+pkgname="$_pkgname-git"
+pkgbase="$_pkgname"
+_gitname="$_pkgname"
+_gitroot="git://github.com/FieryMewtwo/$_gitname.git"
+pkgver=1
+pkgrel=1
+pkgdesc="A simple spinner theme for Plymouth based on plymouth-theme-sweet-arch"
+arch=("any")
+url="https://github.com/FieryMewtwo/$_gitname"
+license=("GPL")
+install="message.install"
+depends=("plymouth")
+makedepends=("git")
+source=($_gitroot)
+sha256sums=("SKIP")
+
+
+package() {
+ cd "$_gitname/$_theme"
+ install -m755 -d "${pkgdir}/usr/share/plymouth/themes/$_theme"
+ install -m644 -t "${pkgdir}/usr/share/plymouth/themes/$_theme" *
+}