summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHikari Hayashi2022-11-28 19:57:54 +0800
committerHikari Hayashi2022-11-28 19:58:29 +0800
commit74f31e4daa9ec98ba981eeef60ad3f69d2df38d1 (patch)
tree0001b36ec92e7db0ebde41261f331830acbc5b49 /PKGBUILD
downloadaur-plymouth-theme-neat.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ea8b81c3be8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hikari Hayashi <rev.hikari@gmail.com>
+
+pkgname=plymouth-theme-neat
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="HiDPI-Friendly Plymouth Theme for Arch Linux"
+url="https://github.com/neetly/plymouth-theme-neat"
+license=(MIT)
+arch=(any)
+depends=(plymouth)
+makedepends=(git)
+source=("$pkgname::git+https://github.com/neetly/plymouth-theme-neat.git#tag=v$pkgver")
+cksums=(SKIP)
+
+package() {
+ cd "$srcdir/$pkgname"
+ (
+ cd ./src
+ find . -exec install -Dm644 "{}" "$pkgdir/usr/share/plymouth/themes/neat/{}" \;
+ )
+ install -Dm644 "./LICENSE" "$pkgdir/usr/share/licenses/plymouth-theme-neat/LICENSE"
+}