summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRudy Matela2015-06-13 19:32:25 +0200
committerRudy Matela2015-06-13 19:32:25 +0200
commit5aff71c9f48b96d909649543081c4f6d0c85c44f (patch)
tree2d2c226cbe039965a999c771a189fb81b06ba7c2 /PKGBUILD
parente717066de5c3a2f3b5b93b7c31d7b6e04a8dd47e (diff)
downloadaur-5aff71c9f48b96d909649543081c4f6d0c85c44f.tar.gz
Conform to the new packaging standards.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b27d70ebb125..b62453bd2be2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rudy Matela <rudy@matela.com.br>
pkgname=pngcheck
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Verifies the integrity of PNG, JNG and MNG files by checking the CRCs and decompressing the image data"
arch=('i686' 'x86_64')
url="http://www.libpng.org/pub/png/apps/pngcheck.html"
@@ -13,18 +13,20 @@ source=("http://sourceforge.net/projects/png-mng/files/$pkgname/$pkgver/$pkgname
'makefile.patch')
md5sums=('980bd6d9a3830fdce746d7fe3c9166ee' 'bd6f2e05f4914e9e271e3b844b489c40')
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ cp Makefile.unx Makefile
+ patch -p0 < $srcdir/makefile.patch
+}
+
build() {
cd $srcdir/$pkgname-$pkgver
- cp Makefile.unx Makefile || return 1
- patch -p0 < $srcdir/makefile.patch || return 1
- make || return 1
- return 0
+ make
}
package() {
cd $srcdir/$pkgname-$pkgver
- install -Dm755 pngcheck $pkgdir/usr/bin/pngcheck || return 1
- install -Dm755 pngsplit $pkgdir/usr/bin/pngsplit || return 1
- install -Dm755 png-fix-IDAT-windowsize $pkgdir/usr/bin/png-fix-IDAT-windowsize || return 1
- return 0
+ install -Dm755 pngcheck $pkgdir/usr/bin/pngcheck
+ install -Dm755 pngsplit $pkgdir/usr/bin/pngsplit
+ install -Dm755 png-fix-IDAT-windowsize $pkgdir/usr/bin/png-fix-IDAT-windowsize
}