summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWebDawg2020-07-02 12:29:11 -0400
committerWebDawg2020-07-02 12:29:11 -0400
commiteb01e19608146fcd2a83ec4399fb603b63f7cb5d (patch)
tree850b11b99ecfee37187df0c578b3811884c92aa5 /PKGBUILD
parente12dcc8473b85300ecc1e4185666de92a6a89fba (diff)
downloadaur-eb01e19608146fcd2a83ec4399fb603b63f7cb5d.tar.gz
added some patches, new version, and now install file with message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b8c50107f8c..aed8f3effaf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+# Maintainer: Web Dawg <webdawg at gmail.com>
+# Contributor: Jonathan Steel <jsteel at archlinux.org>
# Contributor: Alexsandr Pavlov <kidoz at mail dot ru>
# Contributor: Paul Ezvan <paul@ezvan.fr>
pkgname=pnp4nagios
-pkgver=0.6.25
+pkgver=0.6.26
pkgrel=1
pkgdesc="Nagios addon to create graphs from performance data"
arch=('i686' 'x86_64')
@@ -13,11 +14,18 @@ depends=('perl' 'rrdtool' 'php' 'php-gd' 'libtool')
backup=('etc/httpd/conf/extra/pnp4nagios.conf' 'etc/pnp4nagios/config.php'
'etc/pnp4nagios/config_local.php' 'etc/pnp4nagios/npcd.cfg'
'etc/pnp4nagios/process_perfdata.cfg')
+install=pnp4nagios.install
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
npcd.service)
-md5sums=('0cdd3f77606738883af99e5a08986c70'
+md5sums=('7a71b47f70e4e99d52c3b1df334e0342'
'69f82fa4aeebc8c1164d67e4399c0932')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/phpfix.patch"
+ patch --forward --strip=1 --input="${srcdir}/nagiospass.patch"
+}
+
build() {
cd $pkgname-$pkgver