summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjonian2021-09-22 02:36:33 +0300
committerjonian2021-09-22 02:36:33 +0300
commitba8b6741b656be3f405d31ff8ce168dd08f97550 (patch)
treee7963bb2aff370806fead4dbf52fdcbda8f55abc /PKGBUILD
downloadaur-ba8b6741b656be3f405d31ff8ce168dd08f97550.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..513c6adb9a77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=pnpm-bin
+pkgver=6.15.1
+pkgrel=1
+pkgdesc="Fast, disk space efficient package manager"
+arch=("x86_64")
+url="https://github.com/pnpm/pnpm"
+license=("MIT License")
+provides=("pnpm")
+conflicts=("pnpm" "pnpm-git")
+source=("pnpm-$pkgver::$url/releases/download/v${pkgver}/pnpm-linux-x64")
+sha256sums=("6023f98a31d5bfdbd64a467795ec2a3c9ed9318521aacda973b0cff8c365014d")
+
+package() {
+ install -d "$pkgdir/usr/bin" && cp "$srcdir/pnpm-$pkgver" "$_/pnpm"
+ chmod +x "$pkgdir/usr/bin/pnpm"
+}