summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorspider-mario2016-06-15 22:16:07 +0200
committerspider-mario2016-06-15 22:16:07 +0200
commit06d6ae80cc0135381dcc5c9a63c33b608387aac6 (patch)
tree3ee43dc36bee1bb24f1cba029c34081a5f6eabf1 /PKGBUILD
parentb2e06e0290cafea395353e070e7c8d4933278fbf (diff)
downloadaur-06d6ae80cc0135381dcc5c9a63c33b608387aac6.tar.gz
Build with -std=c++11 explicitly
This fixes build issues due to the use of modern math functions.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0da4d7cef6d1..066b6934a1c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib -D_libdir_set=false \
-DCMAKE_BUILD_TYPE=Release \
+ -DEXTRA_KERNEL_CXX_FLAGS='-std=c++11' \
"$srcdir/$pkgname-$pkgver"
make
}